Question:
Pas de vidéo sur HDMI?
Canadian Luke
2012-12-27 03:21:31 UTC
view on stackexchange narkive permalink

Je viens de recevoir mon Raspberry Pi par la poste et je suis allé le brancher à mon téléviseur avec un câble HDMI. J'ai branché le câble (connu pour fonctionner avec mon décodeur câble), un clavier, puis l'alimentation. Une lumière s'allume sur le Raspberry Pi, mais pas d'image.

Dois-je faire quelque chose de spécial en premier? J'ai déjà le système d'exploitation sur une carte flash et il est inséré.

J'ai trouvé un téléviseur avec entrée RCA, avec lequel j'ai pu le brancher. Je sais que le système d'exploitation va bien et je suis passé par l'assistant de configuration. Malheureusement, je ne vois encore rien du côté HDMI.

Une seule LED s'allume, ou plus?
essayez de connecter le câble des deux côtés avant de démarrer le Raspberry Pi. Allumez également le téléviseur et sélectionnez la bonne source avant de commencer. Il y a aussi quelques paramètres dans le fichier config.txt dans le répertoire racine concernant hdmi, peut-être que vous devez changer quelque chose ici pour qu'il fonctionne avec votre téléviseur. bonne chance.
Dix réponses:
#1
+12
Trapias
2013-01-29 21:16:10 UTC
view on stackexchange narkive permalink

J'ai eu un problème similaire avec mon Pi, lorsque je l'ai connecté pour la première fois à mon téléviseur (un Samsung D5000): le téléviseur n'a pas compris qu'un appareil HDMI était connecté. J'ai raspbmc comme système d'exploitation.

Il y a quelques instructions que vous pouvez ajouter à /boot/config.txt pour dire à votre Pi d'activer la sortie HDMI lorsque vous connectez un câble, et pour forcer la sortie HDMI mode au lieu de dvi J'ai ajouté ces lignes, redémarré Pi et j'ai commencé à voir ma framboise à l'écran :)

  config_hdmi_boost = 4hdmi_force_hotplug = 1hdmi_drive = 2  

Référence: Comment forcer le Raspberry Pi à activer HDMI?

#2
+1
Raphael
2019-03-04 12:39:23 UTC
view on stackexchange narkive permalink
  sudo tvservice -p  

activera la sortie HDMI si elle a été désactivée pour une raison quelconque. Découvrez les autres options de cette commande.

Et comment exécuter la commande si je ne parviens pas à accéder à la console?
@CanadianLuke Oh, SSH, bien sûr? Je supposais en quelque sorte que c'était une donnée, vu que les autres réponses concernent l'édition de fichiers. Ce qui, après réflexion, peut probablement être fait en insérant la carte SD dans un lecteur de carte.
#3
  0
Adrian
2012-12-27 04:00:28 UTC
view on stackexchange narkive permalink

Je pense que c'est DVI et non HDMI. Je sais que dans la fiche technique, il est dit HDMI. J'utilise un câble HDMI vers DVI pour afficher l'image à l'écran.

Hdmi est dvi avec son. La qualité est la même, et je doute qu'il utilise hdcp
@CanadianLuke juste pour ajouter, HDMI transporte également un tas de signaux de contrôle pour les contrôles multimédias inter-appareils
#4
  0
Zéychin
2012-12-27 11:35:51 UTC
view on stackexchange narkive permalink

Assurez-vous que toutes les connexions sont sécurisées.

Faites-le avec précaution, mais sûrement. Les premières connexions peuvent être difficiles. Si vous poussez trop fort, vous risquez d'endommager l'appareil. Si vous ne poussez pas assez fort, vous n'aurez peut-être pas une bonne connexion.

Assurez-vous que la carte SD n'est pas placée à l'envers. (Cela arrive.)

Essayez de re-flasher le système d'exploitation sur la carte SD.

Bonne chance et informez-nous de toute mise à jour.

Les connexions sont sécurisées. J'ai essayé de le débrancher et de le brancher. Aucun changement. La carte SD est insérée correctement (elle démarre et je vois la vidéo sur RCA)
Hm. La sortie HDMI peut être mauvaise. Êtes-vous vraiment sur la bonne entrée HDMI sur votre téléviseur? (Toujours bon à vérifier; vous pouvez en avoir plusieurs sur votre téléviseur.)
Au-delà de cela, essayez de mettre à jour votre système d'exploitation vers la dernière version, au cas où il y aurait des corrections de bogues: `sudo apt-get update && apt-get dist-upgrade && apt-get upgrade`.
Le HDMI sur le téléviseur fonctionne et est étiqueté comme HDMI 1. J'ai retiré le câble de mon décodeur câble et l'ai branché sur le RP
Essayez de suivre les instructions répertoriées ici: http://elinux.org/R-Pi_Troubleshooting#No_HDMI_output_at_all
J'essaierai ça ce soir quand je rentrerai à la maison. Ce lien semble également très prometteur pour d'autres problèmes! Merci
J'espère vraiment que vous avez / faites fonctionner votre appareil, @Luke!
Moi aussi ... Je n'ai pas encore eu la chance de le faire: (Putain de vie qui prime ...
Assurez-vous de nous faire savoir si quelque chose a fonctionné pour vous afin que nous puissions aider les autres!
#5
  0
Valente
2015-06-13 17:16:22 UTC
view on stackexchange narkive permalink

J'avais ce problème, j'ai sorti la carte SD, je l'ai réinsérée, puis je l'ai allumée (branchée sous tension) et cela a fonctionné!

#6
  0
arri
2016-02-07 16:05:25 UTC
view on stackexchange narkive permalink

Je viens de traverser toute l'épreuve et je suis finalement allé au petit manuel d'utilisation. Il dit simplement - branchez tout et allumez le téléviseur, mais branchez l'alimentation en dernier. «Tout» signifiait: HDMI; clavier; souris, et; la carte micro SD. Maintenant, la dernière chose que vous allez brancher est le POWER. Cela enverra le PI pour démarrer. Si vous faites cela dans un ordre différent lors de la mise sous tension initiale, cela ne fonctionnera pas. POWER doit être la dernière chose, une fois que tout le nécessaire a été branché.

Vous aviez un manuel avec le vôtre? Et un micro sd?
#7
  0
Jeremiah
2017-04-03 04:59:40 UTC
view on stackexchange narkive permalink

Cela faisait un moment que je n'avais pas utilisé mon Raspberry Pi et quand je l'ai allumé, le système a bien démarré en affichant l'écran de démarrage. Une fois que le système a démarré et que j'ai vu l'arrière-plan pendant une fraction de seconde, l'écran est devenu vide. L'écran de Thr est resté vide à moins que je déplace ma souris. La vidéo ne s'affiche que dans raspbian lors du déplacement de la souris après le démarrage. J'ai maintenu le décalage au démarrage pour la récupération et la réexécution de l'installation. Problème résolu. Plus de problèmes de vidéo. C'était la raspbisn 1.2 car c'était la version fournie avec mon appareil

J'ai essayé tout ce que vous avez tous suggéré sans succès. J'espère que cela aide quelqu'un.

#8
  0
Gorast Cvetkovski
2017-07-19 04:12:57 UTC
view on stackexchange narkive permalink

Mettre config_hdmi_boost à 9 m'a aidé pour mon ancien SONY KDL-46W5500m

Où feriez-vous ce changement?
Dans config.txt. Il suffit de mettre la carte dans n'importe quel lecteur et le dossier est visible sous Windows.
#9
  0
john
2019-09-30 11:33:25 UTC
view on stackexchange narkive permalink

Dans config.txt

commenter

  # dtoverlay = vc4-fkms-v3d  

cela a démarré mon système Je pense qu'une seule sortie HDMI fonctionne, mais je m'en fous. Il a du mal à trouver la vidéo à utiliser et certaines personnes commencent à fonctionner toute seule.

IMO il est extrêmement improbable que cela aide réellement.
#10
-4
Hayden
2016-09-14 19:37:45 UTC
view on stackexchange narkive permalink

Téléchargez le torrent pour le système d'exploitation et non le zip. Vous pouvez également essayer de faire bouger le câble d'alimentation car il peut ne pas avoir assez de puissance



Ce Q&R a été automatiquement traduit de la langue anglaise.Le contenu original est disponible sur stackexchange, que nous remercions pour la licence cc by-sa 3.0 sous laquelle il est distribué.
Loading...